Does Internet Explorer 8 support McAfee?

Answer McAfee requires Microsoft Internet Explorer (IE) 6.0 or a later version, according to McAfee's support. However, Microsoft does acknowledge that there have been some reports of McAfee preventing em... Read More »

Top Q&A For: Does Internet Explorer 8 support McAfee

Does Internet Explorer 7 support Java?

Can Windows 2000 Professional support Internet Explorer 7?

The Microsoft Internet Explorer 7 web browser is not compatible with any version of Windows 2000. In order to use the software, you must upgrade to a newer version of the operating system such as W... Read More »

Does McAfee scan mean McAfee is looking at my files?

is looking for actually cant read a file,just now what the virus is.m

Does my netbook have to have internet explorer and windows explorer?

You should keep your windows explorer - it has nothing to do with your surfing on the net but you need it for your windows operating system.